THREAT ALERT: CVE-2021-44228 is a critical vulnerability resulting in Remote Code Execution (RCE). 

Read Fortress's response to the recent Log4j exploit.

Podcast Episodes

This series of cybersecurity podcasts will focus on Fortress' industry leading services and solutions that protect and reduce an organization's cybersecurity vulnerability. Each podcast will provide insight into Fortress' multi-pronged arsenal for securing an organization's infrastructure against cyber threats and attacks.

Podcast | March 30, 2021

CyberWeek Top Five News

Podcast Episode 2

John Cofrancesco

John CofrancescoVP of Government Solutions

Podcast | March 9, 2021

Getting the Cyber Ball Loading

Podcast Episode 1

John Cofrancesco

John CofrancescoVP of Government Solutions